using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<file_name>(?<id_hx>\d{10})(?<date>\d{8})_(?<hour>\d{6})_(?<ms>\d{6}).*\.LOG\n)(?<hash>\d{0,10}\n)(?<entry>(?:(?:(?:.*),(?:\d{0,3}.){0,})\n){0,})(?<md5>\w{0,33})$";
string input = @"112291123220160811_153118_397769.LOG
4375459
1122911232,20160811,153118,1,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,123456
5aca701c53d911822ab8b0bf01fd82e4
112291123220160811_153118_397769.LOG
4375459
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
5aca701c53d911822ab8b0bf01fd82e4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}