const regex = /^(?<file_name>(?<id_hx>\d{10})(?<date>\d{8})_(?<hour>\d{6})_(?<ms>\d{6}).*\.LOG\n)(?<hash>\d{0,10}\n)(?<entry>(?:(?:(?:.*),(?:\d{0,3}.){0,})\n){0,})(?<md5>\w{0,33})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<file_name>(?<id_hx>\\d{10})(?<date>\\d{8})_(?<hour>\\d{6})_(?<ms>\\d{6}).*\\.LOG\\n)(?<hash>\\d{0,10}\\n)(?<entry>(?:(?:(?:.*),(?:\\d{0,3}.){0,})\\n){0,})(?<md5>\\w{0,33})$', 'gm')
const str = `112291123220160811_153118_397769.LOG
4375459
1122911232,20160811,153118,1,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,123456
5aca701c53d911822ab8b0bf01fd82e4
112291123220160811_153118_397769.LOG
4375459
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
5aca701c53d911822ab8b0bf01fd82e4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}