$re = '/^(?<file_name>(?<id_hx>\d{10})(?<date>\d{8})_(?<hour>\d{6})_(?<ms>\d{6}).*\.LOG\n)(?<hash>\d{0,10}\n)(?<entry>(?:(?:(?:.*),(?:\d{0,3}.){0,})\n){0,})(?<md5>\w{0,33})$/m';
$str = '112291123220160811_153118_397769.LOG
4375459
1122911232,20160811,153118,1,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,123456
5aca701c53d911822ab8b0bf01fd82e4
112291123220160811_153118_397769.LOG
4375459
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10
5aca701c53d911822ab8b0bf01fd82e4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);