import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<file_name>(?<id_hx>\\d{10})(?<date>\\d{8})_(?<hour>\\d{6})_(?<ms>\\d{6}).*\\.LOG\\n)(?<hash>\\d{0,10}\\n)(?<entry>(?:(?:(?:.*),(?:\\d{0,3}.){0,})\\n){0,})(?<md5>\\w{0,33})$";
final String string = "112291123220160811_153118_397769.LOG\n"
+ "4375459\n"
+ "1122911232,20160811,153118,1,172.168.40.10\n"
+ "1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10\n"
+ "1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10\n"
+ "1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10\n"
+ "1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10\n"
+ "1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10\n"
+ "1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10\n"
+ "1122911232,20160811,153118,1,123456\n"
+ "5aca701c53d911822ab8b0bf01fd82e4\n"
+ "112291123220160811_153118_397769.LOG\n"
+ "4375459\n"
+ "1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10\n"
+ "1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10\n"
+ "1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10\n"
+ "1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10\n"
+ "1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10\n"
+ "1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10\n"
+ "1122911232,20160811,153118,1,HX não encontrado na rede,172.168.40.10\n"
+ "5aca701c53d911822ab8b0bf01fd82e4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}