#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?<!(?=((http|https|ftp|ftps?)\:\/\/?)(www\.?)))Nissan(?!(?:([$&+.,/:;\-_#=@?!a-zA-Z0-9](?!\s))+))(?=[^<>]*<)(?!(?:(?!</?(?:a|span)[ >/])(?:.|\n))*</(?:a|span)>)(?! (Micra|is))"
Local $sString = "<p>Nissan is car manufacter odoocompany.</p>" & @CRLF & _
"<p>Nissan</p>" & @CRLF & _
"<p>Nissan. Nissan, Nissan: 'Nissan' "Nissan" Nissan. </p>" & @CRLF & _
"<p>niss 'Nissan' niss</p>" & @CRLF & _
"<p>[Nissan] (Nissan)</p>" & @CRLF & _
"<p>Nissan! www.Nissan.com and www.Nissan.co.in/?nissan=/Nissan.php </p>" & @CRLF & _
"<p>Nissan! www.Nissan.com/nissanis/nissan01/nissan_-ABC/nissan.com</p>" & @CRLF & _
"<p>nissan.com/nissan.html nissan company Nissan Micra is product</p>" & @CRLF & _
"<p><a href="www.Nissan.com">Nissan</a> is company and <span><a href="www.Nissan.com">Nissan</a></span> Micra is product</p>" & @CRLF & _
"<p><span>Nissan</span></p>" & @CRLF & _
"<p>Nissan product <a href="Nissan.com">Nissan</a> ignore Nissan</p>" & @CRLF & _
"<p>nissan <a href="Nissan.com"><span>Nissan</span></a> new nissan</p>" & @CRLF & _
"<p>odoo is a name Company and Nissan Micra is a model of best.</p>" & @CRLF & _
"" & @CRLF & _
"<p>This is new <a href='https://www.Nissan.com'><span>Nissan</span></a> micra of micra nissan is company." & @CRLF & _
"nissan is a company.</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")