re = /(?<!(?=((http|https|ftp|ftps?)\:\/\/?)(www\.?)))Nissan(?!(?:([$&+.,\/:;\-_#=@?!a-zA-Z0-9](?!\s))+))(?=[^<>]*<)(?!(?:(?!<\/?(?:a|span)[ >\/])(?:.|\n))*<\/(?:a|span)>)(?! (Micra|is))/i
str = '<p>Nissan is car manufacter odoocompany.</p>
<p>Nissan</p>
<p>Nissan. Nissan, Nissan: \'Nissan\' "Nissan" Nissan. </p>
<p>niss \'Nissan\' niss</p>
<p>[Nissan] (Nissan)</p>
<p>Nissan! www.Nissan.com and www.Nissan.co.in/?nissan=/Nissan.php </p>
<p>Nissan! www.Nissan.com/nissanis/nissan01/nissan_-ABC/nissan.com</p>
<p>nissan.com/nissan.html nissan company Nissan Micra is product</p>
<p><a href="www.Nissan.com">Nissan</a> is company and <span><a href="www.Nissan.com">Nissan</a></span> Micra is product</p>
<p><span>Nissan</span></p>
<p>Nissan product <a href="Nissan.com">Nissan</a> ignore Nissan</p>
<p>nissan <a href="Nissan.com"><span>Nissan</span></a> new nissan</p>
<p>odoo is a name Company and Nissan Micra is a model of best.</p>
<p>This is new <a href=\'https://www.Nissan.com\'><span>Nissan</span></a> micra of micra nissan is company.
nissan is a company.</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end