import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!(?=((http|https|ftp|ftps?)\\:\\/\\/?)(www\\.?)))Nissan(?!(?:([$&+.,/:;\\-_#=@?!a-zA-Z0-9](?!\\s))+))(?=[^<>]*<)(?!(?:(?!</?(?:a|span)[ >/])(?:.|\\n))*</(?:a|span)>)(?! (Micra|is))";
final String string = "<p>Nissan is car manufacter odoocompany.</p>\n"
+ "<p>Nissan</p>\n"
+ "<p>Nissan. Nissan, Nissan: 'Nissan' \"Nissan\" Nissan. </p>\n"
+ "<p>niss 'Nissan' niss</p>\n"
+ "<p>[Nissan] (Nissan)</p>\n"
+ "<p>Nissan! www.Nissan.com and www.Nissan.co.in/?nissan=/Nissan.php </p>\n"
+ "<p>Nissan! www.Nissan.com/nissanis/nissan01/nissan_-ABC/nissan.com</p>\n"
+ "<p>nissan.com/nissan.html nissan company Nissan Micra is product</p>\n"
+ "<p><a href=\"www.Nissan.com\">Nissan</a> is company and <span><a href=\"www.Nissan.com\">Nissan</a></span> Micra is product</p>\n"
+ "<p><span>Nissan</span></p>\n"
+ "<p>Nissan product <a href=\"Nissan.com\">Nissan</a> ignore Nissan</p>\n"
+ "<p>nissan <a href=\"Nissan.com\"><span>Nissan</span></a> new nissan</p>\n"
+ "<p>odoo is a name Company and Nissan Micra is a model of best.</p>\n\n"
+ "<p>This is new <a href='https://www.Nissan.com'><span>Nissan</span></a> micra of micra nissan is company.\n"
+ "nissan is a company.</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}