package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:-*\d-*){10}$`)
var str = `98-765-432-10
98-765-432-10
-98-765-432-10-
98765432101
9876543210`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}