import re
regex = re.compile(r"^(?:-*\d-*){10}$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("98-765-432-10\n"
"98-765-432-10\n"
"-98-765-432-10-\n"
"98765432101\n"
"9876543210")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")