$re = '/^(?:-*\d-*){10}$/mi';
$str = '98-765-432-10
98-765-432-10
-98-765-432-10-
98765432101
9876543210';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);