re = /^(?:-*\d-*){10}$/mi
str = '98-765-432-10
98-765-432-10
-98-765-432-10-
98765432101
9876543210'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end