#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Content-ID: <http://tempuri\.org/1/636644204289948690>([\s\S]*?)--uuid"
Local $sString = "Content-ID: <http://tempuri.org/1/636644204289948690>" & @CRLF & _
"Content-Transfer-Encoding: binary" & @CRLF & _
"Content-Type: application/octet-stream" & @CRLF & _
"" & @CRLF & _
"%PDF-1.4" & @CRLF & _
"%���� (lots of binary content here)" & @CRLF & _
"" & @CRLF & _
"--uuid:7329cfb8-46a4-40a8-b15b-39b7b0988b57+id=4--"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")