# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Content-ID: <http://tempuri\.org/1/636644204289948690>([\s\S]*?)--uuid"
test_str = ("Content-ID: <http://tempuri.org/1/636644204289948690>\n"
"Content-Transfer-Encoding: binary\n"
"Content-Type: application/octet-stream\n\n"
"%PDF-1.4\n"
"%���� (lots of binary content here)\n\n"
"--uuid:7329cfb8-46a4-40a8-b15b-39b7b0988b57+id=4--")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.