package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Content-ID: <http://tempuri\.org/1/636644204289948690>([\s\S]*?)--uuid`)
var str = `Content-ID: <http://tempuri.org/1/636644204289948690>
Content-Transfer-Encoding: binary
Content-Type: application/octet-stream
%PDF-1.4
%���� (lots of binary content here)
--uuid:7329cfb8-46a4-40a8-b15b-39b7b0988b57+id=4--`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}