import Foundation
let pattern = #"Content-ID: <http://tempuri\.org/1/636644204289948690>([\s\S]*?)--uuid"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Content-ID: <http://tempuri.org/1/636644204289948690>
Content-Transfer-Encoding: binary
Content-Type: application/octet-stream
%PDF-1.4
%���� (lots of binary content here)
--uuid:7329cfb8-46a4-40a8-b15b-39b7b0988b57+id=4--
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)