package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.\\d.
`)
var str = `tranding/h
face/h
hair/h
body/soaps/c
makeup/bb-creams/c
fragrance/eau-de-parfum/c
-1472.87
1;2;3;4;5
134.87
155
-786`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}