import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".\\\\d.\n";
final String string = "tranding/h\n"
+ "face/h\n"
+ "hair/h\n"
+ "body/soaps/c\n"
+ "makeup/bb-creams/c\n"
+ "fragrance/eau-de-parfum/c\n"
+ "-1472.87\n"
+ "1;2;3;4;5\n"
+ "134.87\n"
+ "155\n"
+ "-786";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}