import Foundation
let pattern = #"""
.\\d.
"""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
tranding/h
face/h
hair/h
body/soaps/c
makeup/bb-creams/c
fragrance/eau-de-parfum/c
-1472.87
1;2;3;4;5
134.87
155
-786
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}