re = /.\\d.
/
str = 'tranding/h
face/h
hair/h
body/soaps/c
makeup/bb-creams/c
fragrance/eau-de-parfum/c
-1472.87
1;2;3;4;5
134.87
155
-786'
# Print the match result
str.match(re) do |match|
puts match.to_s
end