use strict;
my $str = '+41 456-7891+23';
my $regex = qr/^(\+)|\D/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";