$re = '/^(\+)|\D/m';
$str = '+41 456-7891+23';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;