import re
regex = re.compile(r"^(\+)|\D", flags=re.MULTILINE)
test_str = "+41 456-7891+23"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)