#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)div class="form-item.*class="form-textarea">[^\n]*\n\K[^\n]*"
Local $sString = "<div class="form-item form-type-textarea form-item-answer2">" & @CRLF & _
"<div class="form-textarea-wrapper resizable"><textarea id="edit-answer2" name="answer2" cols="60" rows="5" class="form-textarea">" & @CRLF & _
"this is some text" & @CRLF & _
"</textarea>" & @CRLF & _
"</div>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")