using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"div class=""form-item.*class=""form-textarea"">[^\n]*\n\K[^\n]*";
string input = @"<div class=""form-item form-type-textarea form-item-answer2"">
<div class=""form-textarea-wrapper resizable""><textarea id=""edit-answer2"" name=""answer2"" cols=""60"" rows=""5"" class=""form-textarea"">
this is some text
</textarea>
</div>
</div>";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}