import re
regex = re.compile(r"div class=\"form-item.*class=\"form-textarea\">[^\n]*\n\K[^\n]*", flags=re.DOTALL)
test_str = ("<div class=\"form-item form-type-textarea form-item-answer2\">\n"
"<div class=\"form-textarea-wrapper resizable\"><textarea id=\"edit-answer2\" name=\"answer2\" cols=\"60\" rows=\"5\" class=\"form-textarea\">\n"
"this is some text\n"
"</textarea>\n"
"</div>\n"
"</div>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")