const regex = /Foo\s+Bar<br\s+\/>(.*)\s*<br \/>/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Foo\\s+Bar<br\\s+\\\/>(.*)\\s*<br \\\/>', 'i')
const str = `Foo Bar<br />BAZ
<br />`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}