$re = '/Foo\s+Bar<br\s+\/>(.*)\s*<br \/>/i';
$str = 'Foo Bar<br />BAZ
<br />';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);