using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(>)\s+(<)|\s+$";
string substitution = @"$1(newcontent)$2";
string input = @"abc> <def
xyz>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}