$re = '/(>)\s+(<)|\s+$/m';
$str = 'abc> <def
xyz>
';
$subst = "$1(newcontent)$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;