package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(>)\s+(<)|\s+$`)
var str = `abc> <def
xyz>
`
var substitution = "$1(newcontent)$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}