using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\{% tag %\}.*?\{% endtag %\})";
string input = @"{% tag %}Lorem ipsum {% endtag %} dolor sit {% tag %} amet{% endtag %}";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}