package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)(\{% tag %\}.*?\{% endtag %\})`)
var str = `{% tag %}Lorem ipsum {% endtag %} dolor sit {% tag %} amet{% endtag %}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}