$re = '/(\{% tag %\}.*?\{% endtag %\})/si';
$str = '{% tag %}Lorem ipsum {% endtag %} dolor sit {% tag %} amet{% endtag %}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);