re = /(\{% tag %\}.*?\{% endtag %\})/i
str = '{% tag %}Lorem ipsum {% endtag %} dolor sit {% tag %} amet{% endtag %}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end