using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[(.*)\] (.+?)\.([A-Z]+): (.*)";
string input = @"[2014-03-24 19:07:08] event.DEBUG: Notified event ""kernel.terminate"" to listener ""Symfony\Component\HttpKernel\EventListener\ProfilerListener::onKernelTerminate""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}