const regex = new RegExp('^\\[(.*)\\] (.+?)\\.([A-Z]+): (.*)', '')
const str = `[2014-03-24 19:07:08] event.DEBUG: Notified event "kernel.terminate" to listener "Symfony\\Component\\HttpKernel\\EventListener\\ProfilerListener::onKernelTerminate"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}