package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\[(.*)\] (.+?)\.([A-Z]+): (.*)`)
var str = `[2014-03-24 19:07:08] event.DEBUG: Notified event "kernel.terminate" to listener "Symfony\Component\HttpKernel\EventListener\ProfilerListener::onKernelTerminate"`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}