re = /^\[(.*)\] (.+?)\.([A-Z]+): (.*)/
str = '[2014-03-24 19:07:08] event.DEBUG: Notified event "kernel.terminate" to listener "Symfony\\Component\\HttpKernel\\EventListener\\ProfilerListener::onKernelTerminate"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end