import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">\\s+<|>\\s*(.*?)\\s*<";
final String string = "<tr class=\"even\">\n"
+ " <td>\n"
+ " Title1\n"
+ " </td>\n"
+ " <td>\n"
+ " Name1\n"
+ " </td>\n"
+ " <td>\n"
+ " Email1\n"
+ " </td>\n"
+ " <td>\n"
+ " Postcode1\n"
+ " </td>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}