re = />\s+<|>\s*(.*?)\s*</
str = '<tr class="even">
<td>
Title1
</td>
<td>
Name1
</td>
<td>
Email1
</td>
<td>
Postcode1
</td>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end