#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*Conference ID\D*([0-9]*).*"
Local $sString = "........................................................................................................................................." & @CRLF & _
"Join online meeting" & @CRLF & _
"https://meet.lync.com/p3group/ralf.klueber/XXXXXXXX" & @CRLF & _
"" & @CRLF & _
"Join by Phone" & @CRLF & _
"+49696670000 (Dial-in Number) Deutsch (Deutschland)" & @CRLF & _
"" & @CRLF & _
"Find a local number" & @CRLF & _
"https://dialin.lync.com/c52ce599-1156-4654-a150-ff021e3a0abc" & @CRLF & _
"" & @CRLF & _
"Conference ID:" & @CRLF & _
"348054656" & @CRLF & _
"" & @CRLF & _
"Forgot your dial-in PIN?" & @CRLF & _
"https://dialin.lync.com/c52ce000-0000-0000-a150-ff021e3a0abc" & @CRLF & _
"......................................................................................................."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")