import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*Conference ID\\D*([0-9]*).*";
final String string = ".........................................................................................................................................\n"
+ "Join online meeting\n"
+ "https://meet.lync.com/p3group/ralf.klueber/XXXXXXXX\n\n"
+ "Join by Phone\n"
+ "+49696670000 (Dial-in Number) Deutsch (Deutschland)\n\n"
+ "Find a local number\n"
+ "https://dialin.lync.com/c52ce599-1156-4654-a150-ff021e3a0abc\n\n"
+ "Conference ID:\n"
+ "348054656\n\n"
+ "Forgot your dial-in PIN?\n"
+ "https://dialin.lync.com/c52ce000-0000-0000-a150-ff021e3a0abc\n"
+ ".......................................................................................................";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}