#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*()\n*)(\s{2})([a-zA_Z0-9]*)(\s{3})(.*)\n(#)([a-zA_Z0-9]*)(#)(\s{1})(.*\s*)()"
Local $sString = " 1 OPTION 1" & @CRLF & _
" 2 OPTION 2" & @CRLF & _
" 3 OPTION 3" & @CRLF & _
" 4 OPTION 4" & @CRLF & _
" 5 OPTION 5" & @CRLF & _
" 6 OPTION 6" & @CRLF & _
" 7 OPTION 7" & @CRLF & _
" 8 OPTION 8" & @CRLF & _
" 9 OPTION 9" & @CRLF & _
" 10 OPTION 10" & @CRLF & _
" 100 OPTION 100" & @CRLF & _
"#1000# OPTION 1000"
Local $sSubst = "$1$2$7$4$7$10$6\n$3$8$5$11"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)