const regex = /(.*()\n*)(\s{2})([a-zA_Z0-9]*)(\s{3})(.*)\n(#)([a-zA_Z0-9]*)(#)(\s{1})(.*\s*)()/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*()\\n*)(\\s{2})([a-zA_Z0-9]*)(\\s{3})(.*)\\n(#)([a-zA_Z0-9]*)(#)(\\s{1})(.*\\s*)()', 'gm')
const str = ` 1 OPTION 1
2 OPTION 2
3 OPTION 3
4 OPTION 4
5 OPTION 5
6 OPTION 6
7 OPTION 7
8 OPTION 8
9 OPTION 9
10 OPTION 10
100 OPTION 100
#1000# OPTION 1000`;
const subst = `$1$2$7$4$7$10$6\n$3$8$5$11`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);