use strict;
my $str = ' 1 OPTION 1
2 OPTION 2
3 OPTION 3
4 OPTION 4
5 OPTION 5
6 OPTION 6
7 OPTION 7
8 OPTION 8
9 OPTION 9
10 OPTION 10
100 OPTION 100
#1000# OPTION 1000';
my $regex = qr/(.*()\n*)(\s{2})([a-zA_Z0-9]*)(\s{3})(.*)\n(#)([a-zA_Z0-9]*)(#)(\s{1})(.*\s*)()/mp;
my $subst = '$1$2$7$4$7$10$6\\n$3$8$5$11';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";