import re
regex = re.compile(r"(.*()\n*)(\s{2})([a-zA_Z0-9]*)(\s{3})(.*)\n(#)([a-zA_Z0-9]*)(#)(\s{1})(.*\s*)()", flags=re.MULTILINE)
test_str = (" 1 OPTION 1\n"
" 2 OPTION 2\n"
" 3 OPTION 3\n"
" 4 OPTION 4\n"
" 5 OPTION 5\n"
" 6 OPTION 6\n"
" 7 OPTION 7\n"
" 8 OPTION 8\n"
" 9 OPTION 9\n"
" 10 OPTION 10\n"
" 100 OPTION 100\n"
"#1000# OPTION 1000")
subst = "$1$2$7$4$7$10$6\\n$3$8$5$11"
result = regex.sub(subst, test_str)
if result:
print(result)