using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\+?[0-9](?:[- ]?[0-9]){9,11}$";
string input = @"+12 1234567890
+12 12 345 567 89
+12 123-455-6789
+9712345567";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}