re = /^\+?[0-9](?:[- ]?[0-9]){9,11}$/m
str = '+12 1234567890
+12 12 345 567 89
+12 123-455-6789
+9712345567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end