package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+?[0-9](?:[- ]?[0-9]){9,11}$`)
var str = `+12 1234567890
+12 12 345 567 89
+12 123-455-6789
+9712345567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}