// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\+?[0-9](?:[- ]?[0-9]){9,11}$").unwrap();
let string = "+12 1234567890
+12 12 345 567 89
+12 123-455-6789
+9712345567";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}